Difference between revisions of "Colori User Guide"

From OCTOPUSCINEMA
Jump to: navigation, search
(Created page with "{{DISPLAYTITLE:Colori}} <div style='text-align: center'><span class="product-headline" style='font-size: 150%'>User Guide</span></div><br><br> ===Getting Started=== <br> ====D...")
 
m
 
(11 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
{{DISPLAYTITLE:Colori}}
 
{{DISPLAYTITLE:Colori}}
 
<div style='text-align: center'><span class="product-headline" style='font-size: 150%'>User Guide</span></div><br><br>
 
<div style='text-align: center'><span class="product-headline" style='font-size: 150%'>User Guide</span></div><br><br>
−
===Getting Started===
+
===Get Started===
 
<br>
 
<br>
 
====Download====
 
====Download====
−
<small>Latest version: 1.1.2</small></br>
+
<small>Latest version: 1.0.1</small></br>
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-macOS-1.1.2.pkg Download for macOS ⬇]</br>
+
[https://www.octopuscinema.com/products/colori/OCTOPUS-Colori-1.0.1.dmg Download for macOS ⬇]</br>
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-Windows-1.1.2.msi Download for Windows ⬇]
+
[https://www.octopuscinema.com/products/colori/OCTOPUS-Colori-1.0.1.msi Download for Windows ⬇]
 
</br>
 
</br>
 
</br>
 
</br>
  
−
====What's new in 1.1.2====
+
====What's new in 1.0.1====
−
* Fixed black screen with some GPUs when decoding in Premiere
+
* Fixed crash on bad effect metadata
 +
* Improved effect remix engine
 
</br>
 
</br>
  
−
====Older Versions====
+
====What's new in 1.0.0====
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-macOS-1.1.0.pkg 1.1.0 (macOS) ⬇]</br>
+
* Initial release
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-Windows-1.1.0.msi 1.1.0 (Windows) ⬇]
 
−
</br></br>
 
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-macOS-1.0.2.pkg 1.0.2 (macOS) ⬇]</br>
 
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-Windows-1.0.2.msi 1.0.2 (Windows) ⬇]
 
−
</br></br>
 
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-macOS-1.0.1.pkg 1.0.1 (macOS) ⬇]</br>
 
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-Windows-1.0.1.msi 1.0.1 (Windows) ⬇]
 
−
</br></br>
 
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-macOS-1.0.0.pkg 1.0.0 (macOS) ⬇]</br>
 
−
[https://www.octopuscinema.com/products/raw-studio/OCTOPUS-RAW-Studio-PremierePro-Windows-1.0.0.msi 1.0.0 (Windows) ⬇]
 
−
</br></br>
 
−
 
 
−
====Prerequisites====
 
−
* OCTOPUS RAW Studio is a plugin for NLE applications. Check your NLE is one of the [[#Supported_Host_Applications|supported host applications]].
 
−
* Check the list of [[#Supported_RAW_formats|supported RAW formats]] to see if your footage will leverage RAW Studio.
 
−
* Check your computer meets the [[#System_Requirements|system requirements]] to run OCTOPUS RAW Studio.
 
−
<br>
 
−
====Installation====
 
−
To install OCTOPUS RAW Studio, launch the appropriate (.pkg for macOS or .msi for Windows) installer for your OS. The installer will automatically copy the RAW Studio plugin components into the appropriate folder for your host NLE application.</br></br>
 
−
<small>Default installation paths for Adobe Premiere Pro:</br></small>
 
−
<small><strong>macOS</strong></small>
 
−
<span class="user-guide-code">/Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore/</span></br>
 
−
<small><strong>Windows</strong></small>
 
−
<span class="user-guide-code">C:\Program Files\Adobe\Common\Plug-Ins\7.0\MediaCore\</span>
 
−
</br>
 
−
<br>
 
−
====Basic Workflow (Premiere Pro)====
 
−
After installation, OCTOPUS RAW Studio’s unified RAW processing pipeline will be active by default for any supported footage imported into Adobe Premiere Pro (see [[#Supported_RAW_formats|supported codecs]]). Footage can be imported into Adobe Premiere Pro in several ways:
 
−
* By dragging media onto the <strong>Project</strong> panel or Timeline area.
 
−
* Via the <strong>File > Import</strong> menus.
 
−
* Browsing to the media location with the <strong>Media Browser</strong> panel.
 
−
<div class='user-guide-tip'>
 
−
<strong>Note</strong></br>For sequence-based formats such as CinemaDNG, it is recommended to drag the first frame of the sequence—OCTOPUS RAW Studio will automatically import all the sequence’s frames.
 
−
</div>
 
−
</br>
 
−
[[File:Basic-workflow-raw-studio.png|thumb|500px|center]]
 
 
</br>
 
</br>
−
Once supported media is imported, the OCTOPUS RAW Studio panel can be found in the <strong>Effect Controls</strong> panel <strong>Source</strong> tab for the clip—the clip must be selected in the <strong>Timeline</strong> or <strong>Project</strong> panel. If the <strong>Effect Controls</strong> panel is not present, it can be accessed from the <strong>Window > Effect Controls</strong> menu.
+
−
 
+
====System Requirements====
−
The OCTOPUS RAW Studio panel can then be used to manipulate RAW processing parameters for all instances of the clip. Each RAW pipeline stage can be customised by changing the <strong>Using</strong> parameter from ''As Shot'' to ''Custom''.
+
Your computer must meet the following technical specifications to run OCTOPUS Colori.
−
<br><br>
+
=====Windows=====
−
====License Activation====
 
−
Once the OCTOPUS RAW Studio panel is visible, your license can be activated by clicking the <strong>Register…</strong> button at the top of the panel.</br></br>
 
−
<small>License information is saved to the following path:</br></small>
 
−
<small><strong>macOS</strong></small>
 
−
<span class="user-guide-code">/Users/[user]/Library/Application Support/OCTOPUSCINEMA/OCTOPUS RAW Studio/licence</span></br>
 
−
<small><strong>Windows</strong></small>
 
−
<span class="user-guide-code">C:\Users\[user]\AppData\Local\OCTOPUSCINEMA\OCTOPUS RAW Studio\licence</span>
 
−
</br></br>
 
−
To deactivate your license, simply delete the appropriate license file for your OS.
 
−
<br><br>
 
−
 
 
−
===Supported Host Applications===
 
−
OCTOPUS RAW Studio currently supports the following host NLE applications:
 
−
* Adobe Premiere Pro 2025
 
−
* Adobe Premiere Pro 2026
 
−
Earlier versions of Premiere Pro may work but have not been thoroughly tested - please evaluate the trial before purchasing a license.
 
−
<br><br>
 
−
 
 
−
===System Requirements===
 
−
Your computer must meet the following technical specifications to run OCTOPUS RAW Studio.
 
−
====Windows====
 
 
{| class="table table-bordered table-sm"
 
{| class="table table-bordered table-sm"
 
|-
 
|-
Line 90: Line 34:
 
|-
 
|-
 
!GPU
 
!GPU
−
|OpenCL 1.2 or NVIDIA CUDA 11.8 compliant
+
|OpenGL 3.2 & OpenCL 1.2 compliant
 
|}
 
|}
 
<br>
 
<br>
−
====macOS====
+
=====macOS=====
 
{| class="table table-bordered table-sm"
 
{| class="table table-bordered table-sm"
 
|-
 
|-
Line 106: Line 50:
 
|-
 
|-
 
!GPU
 
!GPU
−
|Apple Metal compliant
+
|OpenGL 3.2 / OpenCL 1.2 / Apple Metal compliant
 
|}
 
|}
 
<br>
 
<br>
−
===Supported RAW formats===
+
====Installation====
−
OCTOPUS RAW Studio currently supports the following RAW formats.
+
To install OCTOPUS Colori, launch the appropriate (.dmg for macOS or .msi for Windows) installer or container for your OS. On macOS, the .dmg contains the <strong>Colori.app</strong> which can be simply dragged into the <strong>Applications</strong> folder.
 +
<br><br>
 +
 +
===Application Interface===
 +
Colori by default overlays the application interface with a ''glass'' style over the current working media clip. To view the clip without any interface obstruction, go to the <strong>Zoom</strong> control in the top right corner and select <strong>Fit to Space</strong>. To return to overlay mode, select <strong>Fit to Window</strong> in the <strong>Zoom</strong> control.
 +
<div class='user-guide-tip'>
 +
<strong>Hint</strong></br>You can pan and zoom the current media clip with touch gestures or click & drag the mousewheel/rotate the mousewheel.
 +
</div>
 +
<br>
 +
====Panels====
 +
Colori uses expandable and collapsible panels (''Media'', ''Color'' and ''Publish'') to organize the application's functionality. The ''Media'' panel shows the project's imported clips. The ''Color'' panel shows the currently selected clip's color tools/effects. And the ''Publish'' panel is where the project's clips can be chosen for export/publishing. When the working media clip is a video, the playback controls for the clip appear inside the currently active panel.
 +
<br><br>
 +
 +
===Organize Media===
 +
<br>
 +
====Projects====
 +
Colori reads from and saves to Colori project files (<span class="user-guide-code">.colori-proj</span>) to store information about imported clips and their currently assigned color tools/effects.
 +
<br><br>
 +
====Media Panel====
 +
The ''Media'' panel shows all the clips in your project. Here you can remove or import new clips, and make batch changes to clips, such as ''LUT'' and ''Gamma''. Selecting a clip sets it as the currently working media clip for use in the ''Color'' panel.
 +
<div class='user-guide-tip'>
 +
<strong>Hint</strong></br>You can select multiple clips at once by holding the <strong>Control</strong> key on Windows or the <strong>Command</strong> key on macOS.
 +
</div>
 +
<div class='user-guide-tip'>
 +
<strong>Hint</strong></br>To batch copy entire Color tools/effects states, right click a clip and select <strong>Copy Correction State</strong>. Then select your target clips, right click and select <strong>Paste Correction State</strong>.
 +
</div>
 +
<br>
 +
====Import clips====
 +
Clips can be imported into Colori in several ways:
 +
* By dragging media onto the application area.
 +
* Via the <strong>File > Import</strong> menu.
 +
* Clicking the <strong>+</strong> button in the bottom right of the <strong>Media</strong> panel.
 +
<br>
 +
====Supported formats====
 +
Colori currently supports the following media formats.
 +
=====Video formats=====
 
{| class="table table-bordered table-sm"
 
{| class="table table-bordered table-sm"
 
|-
 
|-
−
!Apple ProRes RAW</br><span style="font-weight: normal;">.mov</span>
+
!Apple ProRes
−
|Apple ProRes RAW</br>Apple ProRes RAW HQ
+
|LT</br>Proxy</br>422</br>422 HQ</br>4444</br>4444 XQ
 +
|.mov</br>.mxf
 +
|Decode</br>Encode (PRO subscription)
 
|-
 
|-
−
!CinemaDNG</br><span style="font-weight: normal;">.dng</span>
+
!HEVC
−
|Uncompressed</br>Lossless compressed</br>Lossy compressed</br>Bayer and monochrome
+
|8-bit 4:2:0</br>10-bit 4:2:0 & 4:2:2
 +
|.mov</br>.mp4</br>.mxf
 +
|Decode</br>Encode (PRO subscription)
 +
|-
 +
!H.264
 +
|8-bit 4:2:0
 +
|.mov</br>.mp4</br>.mxf
 +
|Decode</br>Encode
 
|}
 
|}
 
<br>
 
<br>
−
===Color Science===
+
=====Image formats=====
 +
{| class="table table-bordered table-sm"
 +
|-
 +
!PNG
 +
|Decode</br>Encode
 +
|-
 +
!JPEG
 +
|Decode</br>Encode
 +
|-
 +
!WebP
 +
|Decode</br>Encode
 +
|-
 +
!BMP
 +
|Decode only
 +
|-
 +
!HEIF/HEIC
 +
|Decode only
 +
|}
 
<br>
 
<br>
−
====RAW Parameters====
+
=====Audio formats=====
−
Configurable color science parameters are exposed through the OCTOPUS RAW Studio panel user interface. Each stage of the RAW processing pipeline is represented by a sub-section of the interface: ''Detail, Exposure, Tone, Color, Transfer'' and ''Tools''. The <strong>Using</strong> parameter for each region allows switching between default ''As Shot'' camera metadata or ''Custom'' clip specific settings.
+
{| class="table table-bordered table-sm"
−
</br></br>
+
|-
−
 
+
!LPCM Uncompressed
−
=====Detail=====
+
|Decode</br>Encode
−
'''Highlight Recovery''' is our best-in-class proprietary algorithm to maximise usable dynamic range where highlight data is partially clipped (i.e. 1 or 2 channels of the image is clipped).
+
|-
−
</br></br>
+
!AAC
−
'''Texture''' is an optional processing step which simulates signal-to-noise ratios. Analogue texture simulates a celluloid signal-to-noise ratio using a non-linear luminance and chromaticity table. Digital texture simulates CMOS signal-to-noise using linear modulation.
+
|Decode</br>Encode
 +
|}
 +
<br>
 +
 +
===Color tools/effects===
 +
The ''Color'' panel shows the tools currently assigned to the working clip. All clips have an ''Exposure'' and a ''Temperature'' tool.
 
<br><br>
 
<br><br>
−
=====Exposure=====
+
====Exposure====
−
'''Exposure Index''' modifies the ISO regardless of the ISO the clip was shot at. This feature is only available where clips contain ISO metadata.
+
The exposure tool contains controls for adjusting exposure and tonal shape.
 
</br></br>
 
</br></br>
−
'''Ev +/-''' allows for precise relative exposure adjustments.
+
'''Input Gamma''' should be set to the gamma curve the clip was encoded with. See [[#Supported_gamma_spaces|supported gamma spaces]]. When using log gamma curves, the ''Exposure'' slider operates in gamma-correct mode i.e. an ''Exposure'' adjustment of 1.0 applied to ISO800 footage will match ISO1600 footage. The ''Input Gamma'' selection also acts as a hint for data vs video levels in files.
−
<br><br>
 
−
=====Tone=====
 
−
'''Tone''' controls expose standard sliders for shaping the image across the exposure range: ''Contrast, Highlights Shadows'' and ''Blacks''.
 
−
<br><br>
 
−
=====Color=====
 
−
'''White Balance''' controls allow for precise matching of output white reflectance to the color temperature of scene light sources. This can be set either using standard presets for standard light sources or fully customisable with ''Temperature'' and ''Tint'' values.
 
 
</br></br>
 
</br></br>
−
'''Saturation''' is a standard saturation algorithm to remove or add color to the image.
+
'''Exposure''' is a +/- Ev adjustment slider in stops. Can operate in gamma-correct mode – see above.
 
</br></br>
 
</br></br>
−
'''Highlight roll-off''' is our bespoke implementation of filmic roll-off as highlights approach clipping. Our implementation applies a non-linear desaturation curve emulating the desaturation behaviour of celluloid film as it becomes fully transparent. Only applicable for Rec. 709 output.
+
'''Contrast''' is a standard contrast slider implementation.
 
</br></br>
 
</br></br>
−
'''Shadow roll-off''' similar to highlight roll-off, applies a non-linear desaturation curve to shadows as they approach black. Shadow roll-off can help mask the digital nature of CMOS noise in shadows.
+
'''LUT''' allows you to specify a correction LUT to transform from the input gamma space to a target space. Colori has [[#Built-in_LUTs|built-in LUTs]] for popular log gamma spaces to Rec. 709 – or you can load a custom one.
−
<br><br>
 
−
=====Transfer=====
 
−
The Transfer sub-section controls the final stage of RAW processing before the image is transferred to the host NLE application.
 
 
</br></br>
 
</br></br>
−
'''Gamma & Color Spaces''' allow you to choose the output gamma and color space of the image before it is passed to the host NLE application. See supported [[#Supported_transfer_.26_gamma_spaces|gamma spaces]] and [[#Supported_color_spaces|color spaces]].
+
'''Whites''' is a standard tone shaping slider to adjust the brightest parts of the image.
 
</br></br>
 
</br></br>
−
'''LUT''' allows you to apply a look-up table transformation to the image before it is passed to the host NLE application. The LUT option offers [[#Built-in_LUTs|built-in LUTs]] for manufacturer log gamma spaces and custom LUT loading for .cube format LUTs.
+
'''Highlights''' is a standard tone shaping slider to affect just the areas considered highlights of the image.
−
<div class='user-guide-tip'>
 
−
<strong>Note</strong></br>LUTs can only be applied to log gamma spaces and are applied after the gamma and color space transform.
 
−
</div>
 
−
'''Gamut compression''' is an optional step to manage colors outside the range of the output color space. Only applicable for Rec. 709 color space output.
 
 
</br></br>
 
</br></br>
−
'''SDR Tone Mapping''' is recommended because the standard Rec. 709 gamma curve limits images to a narrow dynamic range of 6/7 stops. Applying tone mapping preserves greater dynamic range by compressing all exposure values non-linearly into the standard Rec. 709 range. Only applicable for Rec. 709 gamma space output.
+
'''Shadows''' is a standard tone shaping slider to affect just the areas considered shadows of the image.
 
</br></br>
 
</br></br>
−
'''White Level & Black Level''' allow you to remap the darkest and brightest possible pixel values within the 0.0 to 1.0 range.
+
'''Blacks''' is a standard tone shaping slider to affect just the darkest parts of the image.
 
<br><br>
 
<br><br>
−
 
+
====Temperature====
−
=====Tools=====
+
The temperature tool contains controls for adjusting color temperature and saturation.
−
'''Override & Global Override ‘As Shot’''' allow you to export sidecar metadata either for a clip or ''globally'' for every clip under a folder. ''Overrides'' provide a mechanism to alter the default RAW parameters loaded when clips are set to use ''‘As Shot’'' metadata. For a clip-specific override, use the '''Override ‘As Shot’''' export to create a sidecar with the same name and path as the clip – with the extension: <span class="user-guide-code">.as-shot</span>
 
 
</br></br>
 
</br></br>
−
<small>Clip-specific override example:</br></small>
+
'''White Balance''' provides a color picker to automatically white balance based on a pixel sample of the image.
−
<small><strong>Clip</strong></small>
 
−
<span class="user-guide-code">/Media/A001/MOV_PRORES_RAW_CLIP_01.mov</span></br>
 
−
<small><strong>Sidecar</strong></small>
 
−
<span class="user-guide-code">/Media/A001/MOV_PRORES_RAW_CLIP_01.as-shot</span>
 
 
</br></br>
 
</br></br>
−
For a ''global'' override, use the '''Global override ‘As Shot’''' export to create a sidecar in the same folder as the clip – with the filename: <span class="user-guide-code">global.as-shot</span>
+
'''Temperature''' is a slider to shift the overall color temperature of the image.
 
</br></br>
 
</br></br>
−
<small>Global override example:</br></small>
+
'''Tint''' is a slider to shift to/from green/pink.
−
<small><strong>Clip</strong></small>
 
−
<span class="user-guide-code">/Media/A001/MOV_PRORES_RAW_CLIP_01.mov</span></br>
 
−
<small><strong>Clip</strong></small>
 
−
<span class="user-guide-code">/Media/A001/MOV_PRORES_RAW_CLIP_02.mov</span></br>
 
−
<small><strong>Sidecar</strong></small>
 
−
<span class="user-guide-code">/Media/A001/global.as-shot</span>
 
 
</br></br>
 
</br></br>
−
''Global'' override sidecars will affect all clips in the same folder or subdirectories. In situations where multiple sidecars are in play (i.e. both a ''global'' and clip-specific sidecar present) – the metadata will be automatically merged with clip-specific overrides taking precedence.
+
'''Saturation''' is a standard color saturation implementation.
−
<div class='user-guide-tip'>
 
−
<strong>Note</strong></br>When creating or modifying sidecar files, affected clips may need to be re-imported in Adobe Premiere Pro for changes to take effect.
 
−
</div>
 
−
<div class='user-guide-tip'>
 
−
<strong>Hint</strong></br>Sidecar files are stored in human readable JSON format which can be manually edited in text editing applications.
 
−
</div>
 
 
<br><br>
 
<br><br>
−
 
+
−
====Supported color spaces====
+
====Supported gamma spaces====
−
* Rec. 709
 
−
* Rec. 2020
 
−
* ARRI Alexa Wide Gamut
 
−
* RED Wide Gamut
 
−
* Blackmagic Wide Gamut
 
−
* Blackmagic Film Gen. 1
 
−
* Sony S-Gamut3.Cine
 
−
* Canon Cinema Gamut
 
−
* DJI D-Gamut
 
−
* Panasonic V-Gamut
 
−
* ACES AP1
 
−
* Apple Wide Gamut
 
−
<br>
 
−
 
 
−
====Supported transfer & gamma spaces====
 
 
* Rec. 709
 
* Rec. 709
 
* Rec. 2020 HLG
 
* Rec. 2020 HLG
Line 221: Line 186:
 
* Nikon N-Log
 
* Nikon N-Log
 
* ACEScct
 
* ACEScct
−
* Apple Log 2
 
 
<br>
 
<br>
−
 
+
 
====Built-in LUTs====
 
====Built-in LUTs====
 +
* ACEScct (AP1) to Rec. 709
 +
* Apple Log to Rec. 709
 
* ARRI LogC3 to Rec. 709
 
* ARRI LogC3 to Rec. 709
 
* RED Log3G10 to Rec. 709
 
* RED Log3G10 to Rec. 709
−
* Blackmagic Film Gen. 1 to Rec. 709
+
* Blackmagic Cinema Camera Film to Rec. 709 v2
 
* Blackmagic Film Gen. 5 to Rec. 709
 
* Blackmagic Film Gen. 5 to Rec. 709
 
* Sony S-Log3 (S-Gamut3.Cine) to Rec. 709
 
* Sony S-Log3 (S-Gamut3.Cine) to Rec. 709
Line 234: Line 200:
 
* Panasonic V-Log to Rec. 709
 
* Panasonic V-Log to Rec. 709
 
* Nikon N-Log to Rec. 709
 
* Nikon N-Log to Rec. 709
−
* ACEScct (AP1) to Rec. 709
 
−
* Apple Log 2 to Rec. 709
 
 
<br>
 
<br>
−
 
+
 +
====Adding Tools====
 +
Colori's engine allows for adding any number of tools in addition to the default ''Exposure'' and ''Temperature'' tools. Tools are added by clicking the <strong>+</strong> icon.
 +
<div class='user-guide-tip'>
 +
<strong>Hint</strong></br>Tools are applied in left to right order. All tools bar ''Exposure'' and ''Temperature'' can be re-ordered by dragging.
 +
</div>
 +
<div class='user-guide-tip'>
 +
<strong>Hint</strong></br>Tools can be favourited to quickly copy them to other clips – even in other projects.
 +
</div>
 +
<br>
 +
====Creating tools====
 +
Colori's tool creation engine allows anyone to create their own unique bespoke video tools. To begin creating a tool, simply click the <strong>+</strong> icon in the ''Color'' panel and select <strong>New Prompt</strong>.
 +
</br></br>
 +
You should then describe an image processing routine you want your tool to perform. You can request user interface controls such as sliders and describe what they should do. Colori currently supports ''Sliders, Color pickers'' and ''Drop-down'' user interface controls.
 +
<div class='user-guide-tip'>
 +
<strong>Hint</strong></br>Tools do not have any high-level knowledge of what is in the image. They operate at the pixel level on pixel values. For example, ''‘Add a glow around people’'' will not function as expected. But ''‘Add a glow around bright areas’'' could work well.
 +
</div>
 +
<div class='user-guide-tip' id='privacy'>
 +
<strong>Note</strong></br>Colori creates tools by sending only the prompt text to our cloud AI service. Colori does not ever send any of your image or video clip data. The resulting tool is then run on your local GPU and does not require any internet connectivity to run.
 +
</div>
 +
<br>
 +
====Editing tools====
 +
All tools (apart from ''Exposure'' and ''Temperature'') can be edited and ''‘remixed’'' into something new by simply pressing the <strong>Edit Prompt</strong> button in the lower right corner.
 +
<br><br>
 +
====Built-in Library====
 +
Colori features an extensive built-in tool library for a broad range of scenarios. Tools from the built-in library can also be used in Adobe Premiere. See [[#Sharing_Tools|sharing tools]]. The built-in library uses the same prompt tool engine as tool creation – this means you can edit built-in tools just like other tools.
 +
<br><br>
 +
====Community Library====
 +
In addition to the built-in library, Colori has a community space where creators can share and discuss the video tools they have created. To browse the community library, click <strong>+</strong> in the ''Colori'' panel and select <strong>Community Library</strong>. Tools downloaded from the ''Community Library'' can be imported into by clicking the <strong>+</strong> and selecting <strong>Import .colori-effect</strong>. To share a tool which you have created or ''‘remixed’'' to the community, simply click the <strong>Share</strong> icon in the lower left corner and select <strong>Share to Community</strong>.
 +
<br><br>
 +
====Sharing Tools====
 +
In addition to sharing to the ''Community'', tools can be exported to <span class="user-guide-code">.colori-effect</span> files or shared with Adobe Premiere (requires the free <strong>Colori for Premiere</strong> plugin).
 +
<br><br>
 +
====Scopes====
 +
To the right of the color tools/effects, there is a <strong>Scopes</strong> button which provides a variety of analyses of the working clip's frame.
 +
</br></br>
 +
'''Waveform''' displays a combined analysis of ''red'', ''green'' and ''blue'' channels across the picture. Each line of the image is analyzed from left to right and plotted as a wave graph, with the height indicating the strength of that color in that line.
 +
</br></br>
 +
'''Parade''' shows an analysis of each independent color channel of the image using waveform graphs.
 +
</br></br>
 +
'''Vectorscope''' shows a circular analysis of the hue and saturation found in the image. Hue is represented via the angle of the graph around the center, while saturation is represented by the extent of the graph away from the center. The faint 11 o'clock line represents a universal average skin tone hue angle.
 +
<br><br>
 +
 +
===Publish and Export===
 +
The <strong>Publish</strong> panel provides Colori's publishing and exporting functionality. Colori can publish individual images and videos from a project or a batch of multiple images and/or videos. The list of checkboxes on the <strong>Publish</strong> panel sets which project images and/or videos are marked for publishing. Clicking the ''Up Arrow'' <strong>Publish</strong> button will begin the publishing process.
 +
<div class='user-guide-tip'>
 +
<strong>Hint</strong></br>Colori allows you to fully continue working on your project while the publishing process is active. Colori will internally copy all image/video state so any project changes don't affect publishing.
 +
</div>
 +
<br>
 +
====Publishing single images or videos====
 +
To publish individual images or videos, you can right click on the clip(s) in the <strong>Media</strong> panel and select <strong>Publish</strong>. This will mark just the selected clip(s) for publishing and then navigate you to the <strong>Publish</strong> panel to configure and begin publishing.
 +
<br><br>
 +
====Publishing multiple images and/or videos====
 +
To mark multiple or all project images and/or videos for publishing, select the clips in the <strong>Media</strong> panel and then right click and select <strong>Publish</strong>. Alternatively, you can mark clips for publishing directly in the <strong>Publish</strong> panel by checking the boxes to the left of the project images/videos.
 +
<br><br>
 +
====Publish options====
 +
Colori provides extensive options to configure publishing such as ''codec'', ''bitrate'', ''scaling'' and ''audio quality''. Colori can publish images and videos and provides separate options for video and image files. When publishing more than one image and/or video, the same options are applied to all images and/or videos.
 +
<br><br>
 +
=====File (Video or Images)=====
 +
'''Filename''' is the target filename to publish the selected clip to. When multiple clips are selected, this will match the source.
 +
</br></br>
 +
'''Location''' is the target folder to publish the selected clip(s) to.
 +
<br><br>
 +
=====File (Videos)=====
 +
'''Container''' is the containing file format for publishing videos. See [[#Supported_formats|supported formats]] for supported containers for encoding.
 +
</br></br>
 +
'''Codec''' selects the video codec for publishing. See [[#Supported_formats|supported formats]] for supported encoding codecs.
 +
</br></br>
 +
'''Quality''' selects the video codec's quality for publishing. Video quality options include presets for common video sharing platforms and scenarios but also a ''custom'' mode which offers precise codec control.
 +
<br><br>
 +
=====File (Images)=====
 +
'''Format''' selects the image format to use for publishing. See [[#Supported_formats|supported formats]] for supported image encoding formats.
 +
</br></br>
 +
'''Quality''' offers a simple image format quality slider to trade-off between fidelity and file size (JPEG only).
 +
<br><br>
 +
=====Resize=====
 +
Colori offers multiple image and/or video resizing options when publishing. ''To 4K/UHD/HD'' will scale all images and videos up or down to 4K/UHD/HD while preserving aspect ratio. ''Scale to Width'' and ''Scale to Height'' allow you to target an arbitrary pixel width or height to scale images and videos to while preserving aspect ratio.
 +
<br><br>
 +
=====Audio=====
 +
Audio publishing options appear when publishing videos which contain audio.
 +
</br></br>
 +
'''Codec''' selects the audio codec for publishing. See [[#Supported_formats|supported formats]] for supported audio codecs.
 +
<br><br>
 +
 
===Troubleshooting===
 
===Troubleshooting===
−
To aid troubleshooting, OCTOPUS RAW Studio writes local diagnostic logs while the plugin is active.
+
To aid troubleshooting, Colori writes local diagnostic logs while the application is active.
 
</br></br>
 
</br></br>
 
<small>Diagnostic log path:</br></small>
 
<small>Diagnostic log path:</br></small>
 
<small><strong>macOS</strong></small>
 
<small><strong>macOS</strong></small>
−
<span class="user-guide-code">/Users/[user]/Library/Application Support/OCTOPUSCINEMA/OCTOPUS RAW Studio/Logs/</span></br>
+
<span class="user-guide-code">/Users/[user]/Library/Application Support/OCTOPUSCINEMA/OCTOPUS Colori/Logs/</span></br>
 
<small><strong>Windows</strong></small>
 
<small><strong>Windows</strong></small>
−
<span class="user-guide-code">C:\Users\[user]\AppData\Local\OCTOPUSCINEMA\OCTOPUS RAW Studio\Logs\</span>
+
<span class="user-guide-code">C:\Users\[user]\AppData\Local\OCTOPUSCINEMA\OCTOPUS Colori\Logs\</span>
 
</br></br>
 
</br></br>
 
Please see our [[Support|support]] page for further help.
 
Please see our [[Support|support]] page for further help.
 
</br></br>
 
</br></br>
−
 
+
 
===Uninstalling===
 
===Uninstalling===
 
====Windows====
 
====Windows====
−
To uninstall OCTOPUS RAW Studio from a Windows machine, navigate to '''Settings > Apps > Installed apps'''. Search for or locate ''OCTOPUS RAW Studio'' in the list of applications and select Uninstall from the More options menu.
+
To uninstall Colori from a Windows machine, navigate to '''Settings > Apps > Installed apps'''. Search for or locate ''OCTOPUS Colori'' in the list of applications and select '''Uninstall''' from the ''More options'' menu.
 
====macOS====
 
====macOS====
−
To uninstall OCTOPUS RAW Studio from a macOS machine, it is necessary to manually delete the RAW Studio plugin components from the installation folder. In '''Finder''', navigate to <span class="user-guide-code">/Library/Application Support/Adobe/Common/Plug-ins/7.0/MediaCore/</span> and delete the <span class="user-guide-code">OCTOPUSRawStudio</span> folder.
+
To uninstall Colori from a macOS machine, you can simply drag the Colori application to the Bin.

Latest revision as of 17:03, 10 November 2026

User Guide



Get Started


Download

Latest version: 1.0.1
Download for macOS ⬇
Download for Windows ⬇

What's new in 1.0.1

  • Fixed crash on bad effect metadata
  • Improved effect remix engine


What's new in 1.0.0

  • Initial release


System Requirements

Your computer must meet the following technical specifications to run OCTOPUS Colori.

Windows
Processor Intel® 6th Generation or newer CPU – or AMD Ryzen™ 1000 Series or newer CPU
OS Windows 10 (64-bit) V22H2 or later
Memory 8 GB of RAM
GPU OpenGL 3.2 & OpenCL 1.2 compliant


macOS
Processor Intel® 6th Generation or newer CPU – or Apple silicon M1 or newer
OS macOS Monterey (version 12) or later
Memory 8 GB of RAM
GPU OpenGL 3.2 / OpenCL 1.2 / Apple Metal compliant


Installation

To install OCTOPUS Colori, launch the appropriate (.dmg for macOS or .msi for Windows) installer or container for your OS. On macOS, the .dmg contains the Colori.app which can be simply dragged into the Applications folder.

Application Interface

Colori by default overlays the application interface with a glass style over the current working media clip. To view the clip without any interface obstruction, go to the Zoom control in the top right corner and select Fit to Space. To return to overlay mode, select Fit to Window in the Zoom control.

Hint
You can pan and zoom the current media clip with touch gestures or click & drag the mousewheel/rotate the mousewheel.


Panels

Colori uses expandable and collapsible panels (Media, Color and Publish) to organize the application's functionality. The Media panel shows the project's imported clips. The Color panel shows the currently selected clip's color tools/effects. And the Publish panel is where the project's clips can be chosen for export/publishing. When the working media clip is a video, the playback controls for the clip appear inside the currently active panel.

Organize Media


Projects

Colori reads from and saves to Colori project files (.colori-proj) to store information about imported clips and their currently assigned color tools/effects.

Media Panel

The Media panel shows all the clips in your project. Here you can remove or import new clips, and make batch changes to clips, such as LUT and Gamma. Selecting a clip sets it as the currently working media clip for use in the Color panel.

Hint
You can select multiple clips at once by holding the Control key on Windows or the Command key on macOS.

Hint
To batch copy entire Color tools/effects states, right click a clip and select Copy Correction State. Then select your target clips, right click and select Paste Correction State.


Import clips

Clips can be imported into Colori in several ways:

  • By dragging media onto the application area.
  • Via the File > Import menu.
  • Clicking the + button in the bottom right of the Media panel.


Supported formats

Colori currently supports the following media formats.

Video formats
Apple ProRes LT
Proxy
422
422 HQ
4444
4444 XQ
.mov
.mxf
Decode
Encode (PRO subscription)
HEVC 8-bit 4:2:0
10-bit 4:2:0 & 4:2:2
.mov
.mp4
.mxf
Decode
Encode (PRO subscription)
H.264 8-bit 4:2:0 .mov
.mp4
.mxf
Decode
Encode


Image formats
PNG Decode
Encode
JPEG Decode
Encode
WebP Decode
Encode
BMP Decode only
HEIF/HEIC Decode only


Audio formats
LPCM Uncompressed Decode
Encode
AAC Decode
Encode


Color tools/effects

The Color panel shows the tools currently assigned to the working clip. All clips have an Exposure and a Temperature tool.

Exposure

The exposure tool contains controls for adjusting exposure and tonal shape.

Input Gamma should be set to the gamma curve the clip was encoded with. See supported gamma spaces. When using log gamma curves, the Exposure slider operates in gamma-correct mode i.e. an Exposure adjustment of 1.0 applied to ISO800 footage will match ISO1600 footage. The Input Gamma selection also acts as a hint for data vs video levels in files.

Exposure is a +/- Ev adjustment slider in stops. Can operate in gamma-correct mode – see above.

Contrast is a standard contrast slider implementation.

LUT allows you to specify a correction LUT to transform from the input gamma space to a target space. Colori has built-in LUTs for popular log gamma spaces to Rec. 709 – or you can load a custom one.

Whites is a standard tone shaping slider to adjust the brightest parts of the image.

Highlights is a standard tone shaping slider to affect just the areas considered highlights of the image.

Shadows is a standard tone shaping slider to affect just the areas considered shadows of the image.

Blacks is a standard tone shaping slider to affect just the darkest parts of the image.

Temperature

The temperature tool contains controls for adjusting color temperature and saturation.

White Balance provides a color picker to automatically white balance based on a pixel sample of the image.

Temperature is a slider to shift the overall color temperature of the image.

Tint is a slider to shift to/from green/pink.

Saturation is a standard color saturation implementation.

Supported gamma spaces

  • Rec. 709
  • Rec. 2020 HLG
  • sRGB
  • ARRI LogC3
  • RED Log3G10
  • Blackmagic Film Gen. 1
  • Blackmagic Film Gen. 5
  • Sony S-Log3
  • Canon C-Log2
  • DJI D-Log
  • Panasonic V-Log
  • Nikon N-Log
  • ACEScct


Built-in LUTs

  • ACEScct (AP1) to Rec. 709
  • Apple Log to Rec. 709
  • ARRI LogC3 to Rec. 709
  • RED Log3G10 to Rec. 709
  • Blackmagic Cinema Camera Film to Rec. 709 v2
  • Blackmagic Film Gen. 5 to Rec. 709
  • Sony S-Log3 (S-Gamut3.Cine) to Rec. 709
  • Canon Log 2 to Rec. 709
  • DJI D-Log to Rec. 709
  • Panasonic V-Log to Rec. 709
  • Nikon N-Log to Rec. 709


Adding Tools

Colori's engine allows for adding any number of tools in addition to the default Exposure and Temperature tools. Tools are added by clicking the + icon.

Hint
Tools are applied in left to right order. All tools bar Exposure and Temperature can be re-ordered by dragging.

Hint
Tools can be favourited to quickly copy them to other clips – even in other projects.


Creating tools

Colori's tool creation engine allows anyone to create their own unique bespoke video tools. To begin creating a tool, simply click the + icon in the Color panel and select New Prompt.

You should then describe an image processing routine you want your tool to perform. You can request user interface controls such as sliders and describe what they should do. Colori currently supports Sliders, Color pickers and Drop-down user interface controls.

Hint
Tools do not have any high-level knowledge of what is in the image. They operate at the pixel level on pixel values. For example, ‘Add a glow around people’ will not function as expected. But ‘Add a glow around bright areas’ could work well.

Note
Colori creates tools by sending only the prompt text to our cloud AI service. Colori does not ever send any of your image or video clip data. The resulting tool is then run on your local GPU and does not require any internet connectivity to run.


Editing tools

All tools (apart from Exposure and Temperature) can be edited and ‘remixed’ into something new by simply pressing the Edit Prompt button in the lower right corner.

Built-in Library

Colori features an extensive built-in tool library for a broad range of scenarios. Tools from the built-in library can also be used in Adobe Premiere. See sharing tools. The built-in library uses the same prompt tool engine as tool creation – this means you can edit built-in tools just like other tools.

Community Library

In addition to the built-in library, Colori has a community space where creators can share and discuss the video tools they have created. To browse the community library, click + in the Colori panel and select Community Library. Tools downloaded from the Community Library can be imported into by clicking the + and selecting Import .colori-effect. To share a tool which you have created or ‘remixed’ to the community, simply click the Share icon in the lower left corner and select Share to Community.

Sharing Tools

In addition to sharing to the Community, tools can be exported to .colori-effect files or shared with Adobe Premiere (requires the free Colori for Premiere plugin).

Scopes

To the right of the color tools/effects, there is a Scopes button which provides a variety of analyses of the working clip's frame.

Waveform displays a combined analysis of red, green and blue channels across the picture. Each line of the image is analyzed from left to right and plotted as a wave graph, with the height indicating the strength of that color in that line.

Parade shows an analysis of each independent color channel of the image using waveform graphs.

Vectorscope shows a circular analysis of the hue and saturation found in the image. Hue is represented via the angle of the graph around the center, while saturation is represented by the extent of the graph away from the center. The faint 11 o'clock line represents a universal average skin tone hue angle.

Publish and Export

The Publish panel provides Colori's publishing and exporting functionality. Colori can publish individual images and videos from a project or a batch of multiple images and/or videos. The list of checkboxes on the Publish panel sets which project images and/or videos are marked for publishing. Clicking the Up Arrow Publish button will begin the publishing process.

Hint
Colori allows you to fully continue working on your project while the publishing process is active. Colori will internally copy all image/video state so any project changes don't affect publishing.


Publishing single images or videos

To publish individual images or videos, you can right click on the clip(s) in the Media panel and select Publish. This will mark just the selected clip(s) for publishing and then navigate you to the Publish panel to configure and begin publishing.

Publishing multiple images and/or videos

To mark multiple or all project images and/or videos for publishing, select the clips in the Media panel and then right click and select Publish. Alternatively, you can mark clips for publishing directly in the Publish panel by checking the boxes to the left of the project images/videos.

Publish options

Colori provides extensive options to configure publishing such as codec, bitrate, scaling and audio quality. Colori can publish images and videos and provides separate options for video and image files. When publishing more than one image and/or video, the same options are applied to all images and/or videos.

File (Video or Images)

Filename is the target filename to publish the selected clip to. When multiple clips are selected, this will match the source.

Location is the target folder to publish the selected clip(s) to.

File (Videos)

Container is the containing file format for publishing videos. See supported formats for supported containers for encoding.

Codec selects the video codec for publishing. See supported formats for supported encoding codecs.

Quality selects the video codec's quality for publishing. Video quality options include presets for common video sharing platforms and scenarios but also a custom mode which offers precise codec control.

File (Images)

Format selects the image format to use for publishing. See supported formats for supported image encoding formats.

Quality offers a simple image format quality slider to trade-off between fidelity and file size (JPEG only).

Resize

Colori offers multiple image and/or video resizing options when publishing. To 4K/UHD/HD will scale all images and videos up or down to 4K/UHD/HD while preserving aspect ratio. Scale to Width and Scale to Height allow you to target an arbitrary pixel width or height to scale images and videos to while preserving aspect ratio.

Audio

Audio publishing options appear when publishing videos which contain audio.

Codec selects the audio codec for publishing. See supported formats for supported audio codecs.

Troubleshooting

To aid troubleshooting, Colori writes local diagnostic logs while the application is active.

Diagnostic log path:
macOS /Users/[user]/Library/Application Support/OCTOPUSCINEMA/OCTOPUS Colori/Logs/
Windows C:\Users\[user]\AppData\Local\OCTOPUSCINEMA\OCTOPUS Colori\Logs\

Please see our support page for further help.

Uninstalling

Windows

To uninstall Colori from a Windows machine, navigate to Settings > Apps > Installed apps. Search for or locate OCTOPUS Colori in the list of applications and select Uninstall from the More options menu.

macOS

To uninstall Colori from a macOS machine, you can simply drag the Colori application to the Bin.